F_JT0400 - Log Scanning Error F_JZ119A

Documentation: F_JT0400 - Log Scanning Error F_JZ119A

Error: F_JT0400: Log Scanning Error F_JZ119A

Issue

A Capture job fails with the following error:

F_JT0400: Log scanning error F_JZ119A. Failed to seek to start addr

Environment

  • DSS 6
  • DSS 5
  • Source database: Oracle

Resolution

To resolve this issue, see the scenarios below.

The required log sequence is available

Rewind the Capture job by setting the Capture Start Moment option to one second before the reported error time. This allows the Capture job to begin scanning earlier in the transaction log.

The required log sequence is missing

  1. Run the following query to identify the missing archived log:
    SELECT first_change#, next_change#, name
    FROM V$ARCHIVED_LOG
    WHERE 26862695729 
    BETWEEN first_change# AND next_change#;
    
  2. Restore the identified log from a database backup.
  3. Activate the channel without specifying a Capture Start Moment.

The error persists after restoring the log

Use the dsscontrol command to skip the affected transaction, as indicated in the error message, then perform a Refresh to ensure data consistency.

Cause

This issue may occur for any of the following reasons:

  • The database generated empty logs during maintenance.
  • The cap_state file contains an invalid or corrupted Redo Block Address (RBA) at the checkpoint.
  • The required log sequence is no longer available to the Capture job.
  • We're unable to read the RBA due to log corruption or access issues.