Error - F_JR0570 User Not Found

Documentation: Error - F_JR0570 User Not Found

Error: F_JR0570 User Not Found

Issue

While switching between hubs, the following error appears:

F_JR0570 User <username> Not Found

Environment

DSS 6

Resolution

To resolve this issue, do the following:

  1. Run the following Command Line Interface (CLI) command to export the hub configuration as a JSON file:
    dsshubconfig -o path/to/save/<jsonfilename>.json <hub_name>
    
  2. Open the exported JSON file and locate the Creator field to identify the associated user.
  3. Check whether the username in the Creator field matches the username referenced in the error message and determine whether the user has been deleted.
  4. If both are true, replace the username in the Creator field with the username of an active user.
  5. Import the updated JSON file back into the hub configuration using the following command:
    dsshubconfig -a -i path/to/save/<jsonfilename>.json <hub_name>
    

For more information on using the dsshubconfig command, see our dsshubconfig documentation.

If the username in the Creator field doesn't match the username referenced in the error, or the referenced user is active, contact our support team.

Cause

Each hub's configuration specifies a creator. To function correctly, the hub's creator must be an active user. This issue occurs when the user who creates a hub is deleted, but the hub's configuration isn't updated with an active user's username.